Welcome to FPVDronePilots!
Join our free FPV drone community today!
Sign up

Eachine EV100 + Diversity Pro58 issues

Hamish93

New Member
Joined
Aug 18, 2022
Messages
1
Reaction score
0
Age
29
Hello,

Modded my EV100's about a month ago and added a pro 58 module. Worked flawlessly for about 3 weeks. Now im having problems.

I have made this video to make things clearer :

Basically when i have it all soldered up, it works 1/100 times. The time it works, i see green power on the pro58, i see the oled light up, i get signal on the internal reciever, then hold the button for 3 beeps to connect to av in. Great it works.

The times it doesnt work, i get green LED on module, but nothing on oled. And the internal reciever also does not work.
I have tried everything i can think of.
I have shortened the cables, i have soldered the video line in two different places (Both have worked, but same 1/100) times. I have had the positive line connected to a switch, so the goggles get power, internal reciever connects. then i turn on the module via switch. This worked once, every other time it just drops the connection of the internal reciever.
I have tried wiring the pro58 to a seperate power source.

I have tested the voltage from the battery, from the board, from the battery side of buck 5v converter, from the module side and confirmed 4.92v, i have tested it at the module and confirmed 4.92v aswell.

Basically at a total loss. Only recently got into the hobby and picked up a steal of a deal. Iflight bumblebee v1.3, Eachine tx16s, eachine ev100, a few batterys, charger and bag for £160. Been loving it, Have added a BN-880 gps to the drone and have it all configured and working. Very happy with everything, just would like to get my goggles working with diversity again, as i cant go back to how it was before. My range has more than tripled and the quality seems a bit better aswell.

Really dont want to have to shell out on a pair of fatsharks or something.

Any help is greatly appreciated.

Thanks

ps: If the youtube video isnt HD its because its still processing. Said it would take 5-10 mins to process the HD. That was ages ago.
 

Latest threads

Members online

Forum statistics

Threads
5,161
Messages
40,520
Members
4,472
Latest member
hennery