Welcome to FPVDronePilots!
Join our free FPV drone community today!
Sign up

Radiomaster Pocket ELRS, connection not stable at first start.

MurphysLaw

Member
Joined
Dec 7, 2023
Messages
5
Reaction score
8
Age
34
Hello everybody,

New to the hobby and new to this forum, so go easy on me šŸ˜…šŸ¤£
Just started out flying in real life today after some time in the simulators.
And a lot of reading and discovering about the binding process with the ELRS. And finally got it to work.

But I am encountering a problem which I do not understand.
Have updated both my Radiomaster Pocket ELRS to latest version yesterday, and have updated my analog Mobula 8 to the lastest version as well.

Whenever I want to start flying, I turn the Radiomaster on, and plug in the battery pack of the drone.
It connects, but every second or 3 its connection fails, telemetry lost and so on. Then it connects again and same. (For now, I am flying indoors). Keeps on happening, no stable connection.
The only way it works, is that I go into the ELRS menu on the Radiomaster, and select "Bind". Then it connects after a few seconds, and stays well connected, throughout the entire flying.
But I have to do this every single time I want to go fly.

Is there a way to assign a specific 'channel' on the receiver and transmitter so that the drone and Radiomaster can better communicate at start up?

Radiomaster is set to 50Hz packet rate, output power is set to 100mW.

If anyone has an idea of what I could try, that would be much appreciated.
 
Have updated both my Radiomaster Pocket ELRS to latest version yesterday, and have updated my analog Mobula 8 to the lastest version as well.
In addition to the radio OS and the quad's FC there's firmware for the ELRS module and for the receiver, did you do those too?
 
That I did not know, thanks for giving me that information.
The receiver has been updated since its an AIO on the Mobula 8.
But I will check out if I can find something on the ELRS module on the radio.
 
Yeah if the receiver and module version don't match it could explain the issues.
 
Hello everybody,

New to the hobby and new to this forum, so go easy on me šŸ˜…šŸ¤£
Just started out flying in real life today after some time in the simulators.
And a lot of reading and discovering about the binding process with the ELRS. And finally got it to work.

But I am encountering a problem which I do not understand.
Have updated both my Radiomaster Pocket ELRS to latest version yesterday, and have updated my analog Mobula 8 to the lastest version as well.

Whenever I want to start flying, I turn the Radiomaster on, and plug in the battery pack of the drone.
It connects, but every second or 3 its connection fails, telemetry lost and so on. Then it connects again and same. (For now, I am flying indoors). Keeps on happening, no stable connection.
The only way it works, is that I go into the ELRS menu on the Radiomaster, and select "Bind". Then it connects after a few seconds, and stays well connected, throughout the entire flying.
But I have to do this every single time I want to go fly.

Is there a way to assign a specific 'channel' on the receiver and transmitter so that the drone and Radiomaster can better communicate at start up?

Radiomaster is set to 50Hz packet rate, output power is set to 100mW.

If anyone has an idea of what I could try, that would be much appreciated.
Not to diss this forum, but Search facebook for some of the FPV groups, particularly ā€Beginner to FPV.ā€œ They are incredibly helpful to noobs like me.
 

Members online

No members online now.

Forum statistics

Threads
6,135
Messages
44,720
Members
5,451
Latest member
Zacharyzertuche