Welcome to FPVDronePilots!
Join our free FPV drone community today!
Sign up

My motors spin faster and faster without throttle change. Above a certain speed, I loose throttle authority completely. Any ideas?

Convair

New Member
Joined
Mar 19, 2023
Messages
1
Reaction score
0
Age
20
Hi All,

Everything on my latest FPV drone build works except for the throttle control. The motors spin faster and faster while the throttle is engaged. If I move the throttle down again, the motors get slower but not as slow as when the throttle was in the same position before. It's almost like the throttle input range is drifting upwards. Once the motors reach a certain speed, even returning the throttle right down won't stop the motors. The longer I let them speed up, the faster they speed up. This issue still persists when propellers are attached and the drone is airborne.

I'm using my ESCs with PWM protocol because I haven't got SBUS working yet. Still on PPM. They've been throttle calibrated and firmware-updated to latest BLheli32, as has the flight controller been updated to betaflight 4.4.
I've checked that there aren't any obviously stupid throttle curves in betaflight or in the transmitter.

I've also calibrated the accelerometer, disabled the barometer and tested the drone in my hand to see if the motors respond to changes in orientation without "throttle runaway" as I call it. The motors were perfectly responsive and there was no throttle runaway.

I somehow doubt that any of my hardware is to blame because the pitch and yaw work fine and the rotors hold their speed when I keep the stick still. Even the roll control, which is on the same control stick as the throttle, is able to keep the motors at a constant speed. Hence, I don't think that the transmitter hall module is bad. This also means that the PWM and PPM transmission method are not to blame.

Are there any less obvious settings/hardware faults I've overlooked?

(images and parts list below)

esc
flight controller
2400kv motors
4s battery
receiver
transmitter

IMG_0018.JPG

Screenshot 2023-03-19 044344.png

While I'd love to be asking the forum about real technical questions like getting sbus working, exploring the features on my VTX, getting battery voltage in my OSD and so on, there's no point in doing that until I can get it to fly. Hence, any help is much appreciated.
 
Last edited by a moderator:
I had the same issue with my Beta 95X V3. I was pulling my hair out. Tried everything. Pitch, roll and yaw worked perfectly but as soon as I gave it a little throttle I lost all control of the throttle until I hit the disarm switch. On the forums I was told this was normal on the bench props off or on. I was told to take it out and fly it. Knowing that if it got away from me I could disarm it and drop it to the ground I thought why not. So I did fly it and I'm still scratching my head because it flew like a normal drone and the problem is gone. It was my first FPV drone so I had no idea because I was a newbie and all my experience was with my DJI Mavic Pro Platinum up to that point.
 

New Posts

Members online

Forum statistics

Threads
6,134
Messages
44,718
Members
5,450
Latest member
Wesley