Welcome to FPVDronePilots!
Join our free FPV drone community today!
Sign up

Lizard 95 can't arm

Gurke34

Member
Joined
Sep 18, 2017
Messages
15
Reaction score
10
Age
26
I just received my Lizard 95 and tried to set it up.

So I configured all the usual stuff in betaflight which worked fine so far.
Once I finished and tried to arm it, it didn't arm but started to beep (see in the video).

The aux is configured correctly and works in the "modes" tab.
I enabled airmode so the props should start spinning when I arm it. They also won't when I add throttle after arming.
Motor stop is disabled and throttle is below min_check. The motors work when testing them in betaflight.

I uploade the video here: IMG_2265.MOV
 
Did you check all the stuff in Joshua Bardwells vid? Accelerometer is leveled? What esc protocol are you running, if analog (oneshot/multishot) did you cal the esc's? Is there a failsafe programmed?
None of that should have been a problem out of the box but you never know.
 
  • Like
Reactions: Wayno52
Did you check all the stuff in Joshua Bardwells vid? Accelerometer is leveled? What esc protocol are you running, if analog (oneshot/multishot) did you cal the esc's? Is there a failsafe programmed?
None of that should have been a problem out of the box but you never know.

Thanks for you answer :)
Yes I already tried everything in his video and accelerometer is leveled.
I‘m running dshot600 and yes I do use a failsafe. How would the failsafe stop the quad from arming?
 
Did you set the sub-trim and endpoints in your radio, so that all channels are 1000min, 1500mid and 2000max?

Try turning the accelerometer off.

What are your looptimes? CPU usage is not too high?

Are the models drifting badly on either the welcome screen or on the receivers tab?

Are you plugging in the battery, then quickly placing the quad still and on a level surface?
 
Thanks for you answer :)
Yes I already tried everything in his video and accelerometer is leveled.
I‘m running dshot600 and yes I do use a failsafe. How would the failsafe stop the quad from arming?

Failsafes whole job in life it to kill the quad motors, if it is on the quad wont arm. You can see if failsafe is active on the FC by checking the top of betaflight configurator.

upload_2017-11-12_11-48-6.png

If the parachute is red then the failsafe is active, here is mine with the FS switch turned on

upload_2017-11-12_11-50-53.png
 
  • Like
Reactions: VirtueViolater
Did you set the sub-trim and endpoints in your radio, so that all channels are 1000min, 1500mid and 2000max?

Try turning the accelerometer off.

What are your looptimes? CPU usage is not too high?

Are the models drifting badly on either the welcome screen or on the receivers tab?

Are you plugging in the battery, then quickly placing the quad still and on a level surface?

Gyroloop is 8khz and PIDloop is 2khz - I didn't change them from stock settings.
Neither of the models are drifting and I plug in the battery while the quad already is on a level surface.
Unfortunately, the result was the same with accelerometer turned off - didn't work.
 
Failsafes whole job in life it to kill the quad motors, if it is on the quad wont arm. You can see if failsafe is active on the FC by checking the top of betaflight configurator.

View attachment 1574

If the parachute is red then the failsafe is active, here is mine with the FS switch turned on

View attachment 1575

I just checked that too - FS isn't active, the parachute is grey.

Really starting to wonder what else I can try to fix that :D
 
You can try setting the max safe angle higher. And raising the min throttle check. I can't remember the exact variable names, sorry.

I think the CLI commands are below

set small_angle=
set min_throttle=
set min_check=
Don't forget to do a "save" when you're done or the changes won't stick, you can do a "diff" to make sure what has been tweaked.

For reference I am set to...

set min_check = 1024
set min_throttle = 1024
set small_angle = 180
 
  • Like
Reactions: VirtueViolater
Anytime I get a new FC the first thing I do is get a cli "dump" so I know what was what in the beginning. If you have that you can find out what it was and to be honest, it would drive me nuts not to know what was happening. We know it was likely the accelerometer didn't think the quad was level enough (set small_angle, 180 disables this completely so be careful she will arm in any position now which is nice for dshot turtle mode if you're so inclined) or your throttle was reading above "idle" somehow (even though you said your bottom endpoints were 1000)
 
Hello, I am facing the exact same problem as Gurke above; even his video is identical to mine. But his solutions do not work for me.
This is the original video: IMG_2265.MOV
And same as this video:
except mine Lizard95 beeps when i try to arm it (as in 1st video).

So: the drone is getting the signals of all the 7 channels. I can see that in Betaflight. The airmode and buzzer channels work: since they respond in Betaflight and the buzzer gives signal. The ARM channel (AUX1), also gets a signal but just doenst want to arm. Instead the craft beeps.

Any ideas of you more experienced guys ?

Bye,
Ivo
 
Have you calibrated your channels? I'm not sure about spektrum but it is typically 1000us min, 2000us max with 1500us midpoint. What does the receiver page show for the channel levels with sticks at neutral position?
 

Members online

Forum statistics

Threads
6,135
Messages
44,720
Members
5,451
Latest member
Zacharyzertuche