Welcome to FPVDronePilots!
Join our free FPV drone community today!
Sign up

One ESC out of Four Doesn't Appear in BLHeli Configurator


Nov 16, 2021
Reaction score
Hi all!

So... I have been into FPV drones for ~2 years after my uncle gave me one. It worked great for a little bit (after I fixed it up), but I have had to replace all the parts over the winter, because the build was ≥8 years old.

Here is my setup now:
SpeedyBee F405V3 with 4in1 ESC Stack
SpeedyBee VX800 VTX
RadioMaster RP3 Diversity Receiver
CaddxFPV Starlight Sensor Camera
Jumper T-Lite (builtin ExpressLRS) Transmitter

After a lot of figuring, I finally got the transmitter and receiver to bind with new firmware on both (I had to switch the hardware transmitter to CRSF). I configured the drone in INAV, checked that everything worked and was calibrated, and brought it outside for my first test! Well... I placed it on a flat level surface, armed it successfully from the controller, and moved the throttle up a very tiny bit. Next thing, the drone is spiraling very fast in circles and straight up into the air, completely out of control. I know this is not from my driving skills, as I have gotten pretty good in the simulator and with my drone last year.

Well, it suddenly decided to dive straight down, still spinning in circles very fast no matter what I do on the remote, and after diving through the treetops, smashed into a fence! I finally found it about 30 feet away after a half hour of searching.
Immediate apparent damage:
GPS is shattered; literally
Battery is very damaged
Propellers are shot
Plastic guard on battery connector shattered
Battery velcro strap snapped

All of that is pretty minor I guess.
Well, after hooking it back up to my computer, I test some things, like the motors. Only one works! So I check using the BLHeli Configurator and only ESC #1 shows up. So I re-flash it just to make sure. I then test them all again; now three work! I check the BLHeli Configurator again, and only ESC #2, ESC #3, and ESC #4 show up.

This is ridiculous.

Now, I have also found that the LED strips are burnt. Also, the tx and rx won't connect, although they were at first after the crash. I re-flashed firmware to both but to no avail.

Remember, I just replaced every single one of these parts as I have come up with the funds over the winter, and now that it is spring, It seems as if I might just bin it totally.

I could really use some help from anyone, pretty please? What happened to cause the out of control takeoff to begin with / how to fix ESC #1 etc.
Last edited:

Members online

No members online now.

Forum statistics

Latest member